summaryrefslogtreecommitdiff
path: root/python/python3-decorator/python3-decorator.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/python3-decorator/python3-decorator.SlackBuild')
-rw-r--r--python/python3-decorator/python3-decorator.SlackBuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/python/python3-decorator/python3-decorator.SlackBuild b/python/python3-decorator/python3-decorator.SlackBuild
index a7c7e5ef92..d23a93ab03 100644
--- a/python/python3-decorator/python3-decorator.SlackBuild
+++ b/python/python3-decorator/python3-decorator.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-decorator
# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
SRCNAM=decorator
PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-4.2.1}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,15 +52,17 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.md LICENSE.txt docs/README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a \
+ CHANGES.md LICENSE.txt docs/README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install