summaryrefslogtreecommitdiff
path: root/desktop/dwm/patches/config.mk.diff
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/dwm/patches/config.mk.diff')
-rw-r--r--desktop/dwm/patches/config.mk.diff16
1 files changed, 16 insertions, 0 deletions
diff --git a/desktop/dwm/patches/config.mk.diff b/desktop/dwm/patches/config.mk.diff
new file mode 100644
index 0000000000..086506bc93
--- /dev/null
+++ b/desktop/dwm/patches/config.mk.diff
@@ -0,0 +1,16 @@
+--- config.mk 2010-06-04 05:39:15.000000000 -0500
++++ config.mk 2011-02-19 22:26:00.055940203 -0600
+@@ -16,11 +16,11 @@
+
+ # includes and libs
+ INCS = -I. -I/usr/include -I${X11INC}
+-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
++LIBS = -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+-CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
++CFLAGS = -g -std=c99 -pedantic -Wall ${OPTS} ${INCS} ${CPPFLAGS}
+ #CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+ LDFLAGS = -g ${LIBS}
+ #LDFLAGS = -s ${LIBS}