summaryrefslogtreecommitdiff
path: root/academic/pysam/pysam.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pysam/pysam.SlackBuild')
-rw-r--r--academic/pysam/pysam.SlackBuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/academic/pysam/pysam.SlackBuild b/academic/pysam/pysam.SlackBuild
index c2ff916cc9..f5c3d8615e 100644
--- a/academic/pysam/pysam.SlackBuild
+++ b/academic/pysam/pysam.SlackBuild
@@ -24,10 +24,14 @@
PRGNAM=pysam
-VERSION=${VERSION:-0.15.2}
+VERSION=${VERSION:-0.15.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+#set which python version to install it for
+PYTHON2=false
+PYTHON3=true
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -70,7 +74,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+#use system htslib instead
+export HTSLIB_LIBRARY_DIR=/usr/lib$LIBDIRSUFFIX
+export HTSLIB_INCLUDE_DIR=/usr/include
+
+if $PYTHON2; then
+ python setup.py install --root=$PKG
+fi
+if $PYTHON3; then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true