summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:44 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:03 +0700
commit44e40f5d189425cff717a56f9d5b638d000a94cc (patch)
tree3ab9c4a882554ab755e04d1b950136757e9e78dd /python
parent8497c5289f4ea035e85f13e0a74bf5671ae5633c (diff)
downloadslackbuilds-44e40f5d189425cff717a56f9d5b638d000a94cc.tar.gz
python/python-swiftclient: Renamed python2-swiftclient.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-swiftclient/slack-desc19
-rw-r--r--python/python2-swiftclient/README (renamed from python/python-swiftclient/README)3
-rw-r--r--python/python2-swiftclient/python2-swiftclient.SlackBuild (renamed from python/python-swiftclient/python-swiftclient.SlackBuild)11
-rw-r--r--python/python2-swiftclient/python2-swiftclient.info (renamed from python/python-swiftclient/python-swiftclient.info)2
-rw-r--r--python/python2-swiftclient/slack-desc19
5 files changed, 28 insertions, 26 deletions
diff --git a/python/python-swiftclient/slack-desc b/python/python-swiftclient/slack-desc
deleted file mode 100644
index 065ef754d2..0000000000
--- a/python/python-swiftclient/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-swiftclient: python-swiftclient (OpenStack Object Storage API Client Library)
-python-swiftclient:
-python-swiftclient: This is a python client for the Swift API. There's a Python API
-python-swiftclient: (the swiftclient module), and a command-line script (swift).
-python-swiftclient:
-python-swiftclient: Homepage: https://www.openstack.org/
-python-swiftclient:
-python-swiftclient:
-python-swiftclient:
-python-swiftclient:
-python-swiftclient:
diff --git a/python/python-swiftclient/README b/python/python2-swiftclient/README
index 1a92d37478..a153117012 100644
--- a/python/python-swiftclient/README
+++ b/python/python2-swiftclient/README
@@ -1,4 +1,5 @@
OpenStack Object Storage API Client Library.
This is a python client for the Swift API.
-There's a Python API (the swiftclient module), and a command-line script (swift)
+There's a Python API (the swiftclient module), and a command-line script
+(swift)
diff --git a/python/python-swiftclient/python-swiftclient.SlackBuild b/python/python2-swiftclient/python2-swiftclient.SlackBuild
index 71f3eff24d..929146a997 100644
--- a/python/python-swiftclient/python-swiftclient.SlackBuild
+++ b/python/python2-swiftclient/python2-swiftclient.SlackBuild
@@ -22,7 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-swiftclient
+PRGNAM=python2-swiftclient
+SRCNAM=python-swiftclient
VERSION=${VERSION:-3.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-swiftclient/python-swiftclient.info b/python/python2-swiftclient/python2-swiftclient.info
index 96234c284d..ec7a2cf2b2 100644
--- a/python/python-swiftclient/python-swiftclient.info
+++ b/python/python2-swiftclient/python2-swiftclient.info
@@ -1,4 +1,4 @@
-PRGNAM="python-swiftclient"
+PRGNAM="python2-swiftclient"
VERSION="3.2.0"
HOMEPAGE="https://www.openstack.org/"
DOWNLOAD="https://pypi.python.org/packages/34/f5/d4702a0715ae9ffe4d66c5d519504b18757c6573aaa10af3790a6bdcb7ce/python-swiftclient-3.2.0.tar.gz"
diff --git a/python/python2-swiftclient/slack-desc b/python/python2-swiftclient/slack-desc
new file mode 100644
index 0000000000..b5f78ab9f1
--- /dev/null
+++ b/python/python2-swiftclient/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-swiftclient: python2-swiftclient (OpenStack Object Storage API Client Library)
+python2-swiftclient:
+python2-swiftclient: This is a python client for the Swift API. There's a Python API
+python2-swiftclient: (the swiftclient module), and a command-line script (swift).
+python2-swiftclient:
+python2-swiftclient: Homepage: https://www.openstack.org/
+python2-swiftclient:
+python2-swiftclient:
+python2-swiftclient:
+python2-swiftclient:
+python2-swiftclient: