summaryrefslogtreecommitdiff
path: root/python/python-tvrage
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:44 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:03 +0700
commitc8ba3352dd90b4ddc3b4a563a7ad6754cd64ec20 (patch)
treed3d1170af137c6c458062a1dfe690c64c1266264 /python/python-tvrage
parent44e40f5d189425cff717a56f9d5b638d000a94cc (diff)
downloadslackbuilds-c8ba3352dd90b4ddc3b4a563a7ad6754cd64ec20.tar.gz
python/python-tvrage: Renamed python2-tvrage.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-tvrage')
-rw-r--r--python/python-tvrage/README2
-rw-r--r--python/python-tvrage/python-tvrage.SlackBuild85
-rw-r--r--python/python-tvrage/python-tvrage.info10
-rw-r--r--python/python-tvrage/slack-desc19
4 files changed, 0 insertions, 116 deletions
diff --git a/python/python-tvrage/README b/python/python-tvrage/README
deleted file mode 100644
index f2c0f9ea95..0000000000
--- a/python/python-tvrage/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Python-tvrage is a client interface for tvrage.com's
-XML-based api feeds.
diff --git a/python/python-tvrage/python-tvrage.SlackBuild b/python/python-tvrage/python-tvrage.SlackBuild
deleted file mode 100644
index 6624c357cf..0000000000
--- a/python/python-tvrage/python-tvrage.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-tvrage
-
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-tvrage
-VERSION=${VERSION:-0.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE NEWS README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-tvrage/python-tvrage.info b/python/python-tvrage/python-tvrage.info
deleted file mode 100644
index 264a2676b2..0000000000
--- a/python/python-tvrage/python-tvrage.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-tvrage"
-VERSION="0.4.1"
-HOMEPAGE="https://github.com/ckreutzer/python-tvrage"
-DOWNLOAD="https://github.com/ckreutzer/python-tvrage/archive/0.4.1.tar.gz"
-MD5SUM="13a832233ac51e76fe0b1e61a68b32ed"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="BeautifulSoup"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-tvrage/slack-desc b/python/python-tvrage/slack-desc
deleted file mode 100644
index f6acfedf90..0000000000
--- a/python/python-tvrage/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-tvrage: python-tvrage (client interface for tvrage.com)
-python-tvrage:
-python-tvrage: python-tvrage is a client interface for tvrage.com's
-python-tvrage: XML-based api feeds.
-python-tvrage:
-python-tvrage: Homepage: https://github.com/ckreutzer/python-tvrage
-python-tvrage:
-python-tvrage:
-python-tvrage:
-python-tvrage:
-python-tvrage: