summaryrefslogtreecommitdiff
path: root/python/artifacts
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-15 16:28:25 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:09 +0700
commitcab574e3127be7782983370581d24fdd17aa3b36 (patch)
treedc298453ca645cd3f792e04af953912713ca9188 /python/artifacts
parent40ac17851ab43634a779679cfafbd3da1ef8f982 (diff)
downloadslackbuilds-cab574e3127be7782983370581d24fdd17aa3b36.tar.gz
python/artifacts: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/artifacts')
-rw-r--r--python/artifacts/artifacts.SlackBuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/artifacts/artifacts.SlackBuild b/python/artifacts/artifacts.SlackBuild
index fdef0ad23f..39ff928142 100644
--- a/python/artifacts/artifacts.SlackBuild
+++ b/python/artifacts/artifacts.SlackBuild
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true