summaryrefslogtreecommitdiff
path: root/libraries/tlsh
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2022-04-19 18:34:58 -0400
committerB. Watson <yalhcru@gmail.com>2022-04-19 18:34:58 -0400
commit6f72cac18d27e6df9c1c3c6d8d46fca60d2759b8 (patch)
treefc9217f2cbc0a6d3e679fbc89b0d9123e0be3492 /libraries/tlsh
parent56f69491d0ca48fa0e38e24efe7264f6bb9f6c72 (diff)
downloadslackbuilds-6f72cac18d27e6df9c1c3c6d8d46fca60d2759b8.tar.gz
libraries/tlsh: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/tlsh')
-rw-r--r--libraries/tlsh/tlsh.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/libraries/tlsh/tlsh.SlackBuild b/libraries/tlsh/tlsh.SlackBuild
index ff1d5d968f..4db0ab69bd 100644
--- a/libraries/tlsh/tlsh.SlackBuild
+++ b/libraries/tlsh/tlsh.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix doc permissions.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tlsh
VERSION=${VERSION:-4.8.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +75,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
sed '/set(CMAKE_EXE_LINKER_FLAGS/d' -i CMakeLists.txt
sed '/set(CMAKE_CXX_FLAGS/d' -i CMakeLists.txt
@@ -111,7 +111,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.pdf LICENSE NOTICE.txt PUBLIC.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+install -m0644 *.pdf LICENSE NOTICE.txt PUBLIC.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install