summaryrefslogtreecommitdiff
path: root/games/SpaceZero/Makefile.patch
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2014-04-10 07:34:12 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-10 07:34:12 +0700
commit54201de6cf4bd5f4a94ba4db8dd2e156b5446014 (patch)
treee9c9eda5602301a8da5ce0a42f662bd719288ec1 /games/SpaceZero/Makefile.patch
parentbc3a95bf5d210c7533523ea89a5df1cd122817c0 (diff)
downloadslackbuilds-54201de6cf4bd5f4a94ba4db8dd2e156b5446014.tar.gz
games/SpaceZero: Added (space game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/SpaceZero/Makefile.patch')
-rw-r--r--games/SpaceZero/Makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/SpaceZero/Makefile.patch b/games/SpaceZero/Makefile.patch
new file mode 100644
index 0000000000..4d9fab2351
--- /dev/null
+++ b/games/SpaceZero/Makefile.patch
@@ -0,0 +1,25 @@
+--- spacezero/Makefile.original 2014-04-07 20:07:25.673407307 +0300
++++ spacezero/Makefile 2014-04-07 20:08:30.901591842 +0300
+@@ -9,11 +9,11 @@
+ RECORDFILE=$(CONFIGDIR)/record
+
+ # The binary executable will be copied in the next directory.
+-INSTALL_DIR=/usr/local/games
++INSTALL_DIR=/usr/bin
+
+ # All data files will be copied in the next directory.
+ # tar.gz
+-INSTALL_DATA_DIR=/usr/local/share/spacezero
++INSTALL_DATA_DIR=/usr/share/games/SpaceZero
+
+ # DEB pkg
+ #INSTALL_DIR=/usr/games
+@@ -27,7 +27,7 @@
+ GTKFLAGS12=`gtk-config --libs`
+
+ CFLAGS= -Wall -O3 --pedantic -I./include -DDATADIR=\"$(DATADIR)\" -DINSTALL_DATA_DIR=\"$(INSTALL_DATA_DIR)\"
+-LDFLAGS= -lm -lpthread $(SOUNDFLAGS) $(GTKLIBS)
++LDFLAGS= -lm -lpthread -lX11 -lXext -ldl $(SOUNDFLAGS) $(GTKLIBS)
+
+ # DEB pkg
+ #CFLAGS += `dpkg-buildflags --get CFLAGS`