summaryrefslogtreecommitdiff
path: root/academic/Kst
diff options
context:
space:
mode:
authorFellype do Nascimento <fellypao@yahoo.com.br>2022-03-01 10:17:10 -0300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-03 15:56:37 +0700
commit8204b0bd3db3ace60a4bf304c042df3af1f1f5ad (patch)
treeed75a78ef54260418572d096d23ec3de867ff211 /academic/Kst
parentbb97a3d11e6c79064cf18c61315d82b191c03553 (diff)
downloadslackbuilds-8204b0bd3db3ace60a4bf304c042df3af1f1f5ad.tar.gz
academic/Kst: patch to fix the path for H5Cpp.h file
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/Kst')
-rw-r--r--academic/Kst/Kst.SlackBuild28
-rw-r--r--academic/Kst/Kst.info2
-rw-r--r--academic/Kst/fix_hdf5_path.patch11
3 files changed, 37 insertions, 4 deletions
diff --git a/academic/Kst/Kst.SlackBuild b/academic/Kst/Kst.SlackBuild
index 0ae8d4632f..25dd19977b 100644
--- a/academic/Kst/Kst.SlackBuild
+++ b/academic/Kst/Kst.SlackBuild
@@ -1,8 +1,27 @@
#!/bin/bash
+
# Slackware build script for Kst
-# Based on Slackware 14.1 SlackBuild and AUR PKGBUILD for Kst
-# Written by Fellype do Nascimento <fellype(at)gmail.com>
-# last modification of this build script: 2014/12/10
+# Copyright 2014-2022 Fellype do Nascimento, Guaratingueta, Brazil
+# SBo team have contributed to the maintenance of this build script :)
+#
+# Based on Slackware 15.0 SlackBuild and AUR PKGBUILD for Kst
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
@@ -55,6 +74,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix the path for H5Cpp.h
+patch -p1 < $CWD/fix_hdf5_path.patch src/datasources/hdf5/hdf5.h
+
# Fix an issue with the newer cmake
sed -i "s|else(GCC|elseif(GCC|" CMakeLists.txt || exit 1
diff --git a/academic/Kst/Kst.info b/academic/Kst/Kst.info
index bb94664b66..9ade76a485 100644
--- a/academic/Kst/Kst.info
+++ b/academic/Kst/Kst.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="scipy"
MAINTAINER="Fellype do Nascimento"
-EMAIL="fellype(at)gmail.com"
+EMAIL="fellype (at) gmail (dot) com"
diff --git a/academic/Kst/fix_hdf5_path.patch b/academic/Kst/fix_hdf5_path.patch
new file mode 100644
index 0000000000..bcdc1403ae
--- /dev/null
+++ b/academic/Kst/fix_hdf5_path.patch
@@ -0,0 +1,11 @@
+--- Kst-20220116_2b8e03e/src/datasources/hdf5/hdf5.h 2022-01-15 22:42:17.000000000 -0300
++++ Kst-20220116_2b8e03e/src/datasources/hdf5/hdf5.h.new 2022-03-01 09:50:10.407808017 -0300
+@@ -18,7 +18,7 @@
+ #include <dataplugin.h>
+
+ #include <QFileInfo>
+-#include <hdf5/serial/H5Cpp.h>
++#include <H5Cpp.h>
+ #include <exception>
+
+ #include "debug.h"