summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-10-22 01:27:47 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-29 10:28:32 +0700
commitd58322e2c29267c5e94c6684a4982edadb320a53 (patch)
treecdccf85f3bef230956a134c9a50be34bdcaf0c3b
parent561edcd84afea0fe68ec7e034bc3cea34caa8e33 (diff)
downloadslackbuilds-d58322e2c29267c5e94c6684a4982edadb320a53.tar.gz
development/jupyter-nbconvert: Updated for version 7.2.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild15
-rw-r--r--development/jupyter-nbconvert/jupyter-nbconvert.info10
2 files changed, 19 insertions, 6 deletions
diff --git a/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild b/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
index c7b28fe1ec..cb66c99ed5 100644
--- a/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
+++ b/development/jupyter-nbconvert/jupyter-nbconvert.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-nbconvert
-VERSION=${VERSION:-6.5.0}
+VERSION=${VERSION:-7.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,7 +82,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Build jupyter-nbconvert offline
+# Code taken from Gentoo science project:
+# https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-python/nbconvert/nbconvert-7.1.0.ebuild
+sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' -i hatch_build.py
+
+# Import style.min.css into classic templates
+mkdir -p $TMP/$SRCNAM-$VERSION/share/templates/classic/static
+cp $CWD/style.min.css $TMP/$SRCNAM-$VERSION/share/templates/classic/static/style.css
+
+# wheel build requires offline style.css
+python3 -m build --wheel --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/development/jupyter-nbconvert/jupyter-nbconvert.info b/development/jupyter-nbconvert/jupyter-nbconvert.info
index 27a68b02e1..c055f48bb4 100644
--- a/development/jupyter-nbconvert/jupyter-nbconvert.info
+++ b/development/jupyter-nbconvert/jupyter-nbconvert.info
@@ -1,10 +1,12 @@
PRGNAM="jupyter-nbconvert"
-VERSION="6.5.0"
+VERSION="7.2.2"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbconvert/nbconvert-6.5.0.tar.gz"
-MD5SUM="486a48c4dc3986e8801058273964d189"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbconvert/nbconvert-7.2.2.tar.gz \
+ https://cdn.jupyter.org/notebook/5.4.0/style/style.min.css"
+MD5SUM="cb6368f15406efc8d41e2de9641f9570 \
+ 47782e517c98a53adb514cbefb4528f2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="bleach python3-defusedxml jupyter-nbclient jupyterlab_pygments mistune pandocfilters testpath BeautifulSoup4 tinycss2"
+REQUIRES="bleach python3-defusedxml jupyter-nbclient jupyterlab_pygments python3-mistune pandocfilters testpath BeautifulSoup4 tinycss2 python3-hatchling"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"