summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2021-11-21 04:05:23 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-12-04 10:08:56 +0700
commitd1db0bacf0c6a0e79cedbbd7690a7af17f91f977 (patch)
tree35cf633eedfbcaf5dd5c969e1eab2f394691a5d4
parent31cbafab5437f3c911a7c0d0ecee325a4f7395a0 (diff)
downloadslackbuilds-d1db0bacf0c6a0e79cedbbd7690a7af17f91f977.tar.gz
system/lirc: Docs in /usr/doc, not /usr/share/doc.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/lirc/README16
-rw-r--r--system/lirc/lirc.SlackBuild26
2 files changed, 25 insertions, 17 deletions
diff --git a/system/lirc/README b/system/lirc/README
index b73cf20eb3..5117ea673e 100644
--- a/system/lirc/README
+++ b/system/lirc/README
@@ -1,10 +1,10 @@
-LIRC is a package that allows you to decode and send infra-red signals of many
-(but not all) commonly used remote controls.
+LIRC is a package that allows you to decode and send infra-red signals
+of many (but not all) commonly used remote controls.
-Former versions focussed on home-brew hardware connected to the serial or
-parallel port. Current versions of LIRC also support a variety of other
-hardware.
+Former versions focussed on home-brew hardware connected to the serial
+or parallel port. Current versions of LIRC also support a variety of
+other hardware.
-NOTE: for FTDI chips support you need install libftdi and ftdi_eeprom from
-http://www.intra2net.com/en/developer/libftdi/
-before running the slackbuild.
+NOTE: for FTDI chips support you need install libftdi and ftdi_eeprom
+from http://www.intra2net.com/en/developer/libftdi/ before running the
+SlackBuild.
diff --git a/system/lirc/lirc.SlackBuild b/system/lirc/lirc.SlackBuild
index c07a4ce180..3ce16f127d 100644
--- a/system/lirc/lirc.SlackBuild
+++ b/system/lirc/lirc.SlackBuild
@@ -25,11 +25,15 @@
# Modified for 0.9.3a by Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# 20211121 bkw: BUILD=3. install all docs to
+# /usr/doc/$PRGNAM-$VERSION, instead of /usr/share/doc/$PRGNAM. Also
+# don't include useless INSTALL in doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lirc
VERSION=${VERSION:-0.9.3a}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -100,7 +104,10 @@ CXXFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make -j1
-make install DESTDIR=$PKG
+
+# 20211121 bkw: the top-level Makefile doesn't pass docdir to
+# doc/Makefile, unless we set it here also.
+make install DESTDIR=$PKG docdir=/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/lib/udev/rules.d
cat contrib/lirc.rules > $PKG/lib/udev/rules.d/96-lirc.rules
@@ -119,14 +126,15 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
# This is an empty file :|
rm -f $PKG/usr/man/man1/smode2.1.gz
-# Fixup doc owner & mode
-chown -R root:root $PKG/usr/share/doc/lirc/lirc.org/api-docs
-chmod -R go-w $PKG/usr/share/doc/lirc/lirc.org/api-docs
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README \
- doc/{html,irxevent.keys} $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# HTML docs are already installed in $PKGDOC/html
+cp -a AUTHORS COPYING ChangeLog NEWS README doc/irxevent.keys $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+# Fixup doc owner & mode
+chown -R root:root $PKGDOC
+chmod -R go-w $PKGDOC
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc