summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerban Udrea <S.Udrea@gsi.de>2022-11-08 20:06:15 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-12 22:33:20 +0700
commit4db10eb3101db0293dde34570a6958cbc5322055 (patch)
tree17c61b1d66b3cd24c898967a75a28b4e3262c4da
parentb775f3e2b983b8b2edf51c454560ad2c5c8c5b13 (diff)
downloadslackbuilds-4db10eb3101db0293dde34570a6958cbc5322055.tar.gz
development/cycler: Removed (renamed python2-cycler).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/cycler/README2
-rw-r--r--development/cycler/cycler.SlackBuild82
-rw-r--r--development/cycler/cycler.info10
-rw-r--r--development/cycler/slack-desc19
4 files changed, 0 insertions, 113 deletions
diff --git a/development/cycler/README b/development/cycler/README
deleted file mode 100644
index 796b6408b1..0000000000
--- a/development/cycler/README
+++ /dev/null
@@ -1,2 +0,0 @@
-The cycler python module provides a composable cycle class used for
-constructing style-cycles.
diff --git a/development/cycler/cycler.SlackBuild b/development/cycler/cycler.SlackBuild
deleted file mode 100644
index 2126bde2a0..0000000000
--- a/development/cycler/cycler.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for cycler
-
-# Copyright 2016-2017 Serban Udrea <s.udrea@gsi.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification,
-# is permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
-# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
-# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=cycler
-VERSION=${VERSION:-0.10.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/cycler/cycler.info b/development/cycler/cycler.info
deleted file mode 100644
index cad6834a62..0000000000
--- a/development/cycler/cycler.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="cycler"
-VERSION="0.10.0"
-HOMEPAGE="http://matplotlib.org/cycler"
-DOWNLOAD="https://pypi.python.org/packages/c2/4b/137dea450d6e1e3d474e1d873cd1d4f7d3beed7e0dc973b06e8e10d32488/cycler-0.10.0.tar.gz"
-MD5SUM="4cb42917ac5007d1cdff6cccfe2d016b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Serban Udrea"
-EMAIL="S.Udrea@gsi.de"
diff --git a/development/cycler/slack-desc b/development/cycler/slack-desc
deleted file mode 100644
index 8fe6777d56..0000000000
--- a/development/cycler/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-cycler: cycler (composable cycles in python)
-cycler:
-cycler: The cycler python module provides a composable cycle class used for
-cycler: constructing style-cycles.
-cycler:
-cycler:
-cycler:
-cycler: Homepage: http://matplotlib.org/cycler
-cycler:
-cycler:
-cycler: