summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2022-01-30 17:24:23 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-02 11:23:19 +0700
commit20caeff17da32a2a9775e842ae62399a251fffb4 (patch)
treea7d394bbc95c09f3d0142a9bafed3934b4f90dbf
parent29b73deaf37303dcf20b8ccb289495a58928f329 (diff)
downloadslackbuilds-20caeff17da32a2a9775e842ae62399a251fffb4.tar.gz
network/yt-dlp: Added (download videos from youtube).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/yt-dlp/README5
-rw-r--r--network/yt-dlp/slack-desc19
-rw-r--r--network/yt-dlp/yt-dlp.SlackBuild75
-rw-r--r--network/yt-dlp/yt-dlp.info10
4 files changed, 109 insertions, 0 deletions
diff --git a/network/yt-dlp/README b/network/yt-dlp/README
new file mode 100644
index 0000000000..c2c3676d77
--- /dev/null
+++ b/network/yt-dlp/README
@@ -0,0 +1,5 @@
+yt-dlp (download videos from youtube)
+
+yt-dlp is a youtube-dl fork based on the now inactive youtube-dlc. The
+main focus of this project is adding new features and patches while
+also keeping up to date with the original project.
diff --git a/network/yt-dlp/slack-desc b/network/yt-dlp/slack-desc
new file mode 100644
index 0000000000..a57ef03f5b
--- /dev/null
+++ b/network/yt-dlp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+yt-dlp: yt-dlp (download videos from youtube)
+yt-dlp:
+yt-dlp: yt-dlp is a youtube-dl fork based on the now inactive youtube-dlc. The
+yt-dlp: main focus of this project is adding new features and patches while
+yt-dlp: also keeping up to date with the original project.
+yt-dlp:
+yt-dlp:
+yt-dlp:
+yt-dlp:
+yt-dlp:
+yt-dlp:
diff --git a/network/yt-dlp/yt-dlp.SlackBuild b/network/yt-dlp/yt-dlp.SlackBuild
new file mode 100644
index 0000000000..de98b0fa8f
--- /dev/null
+++ b/network/yt-dlp/yt-dlp.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/bash
+
+# Slackware build script for yt-dlp
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# Note: I honestly prefer the standalone executable version of this,
+# which I keep in ~/bin. It allows me to run "yt-dlp -U" as my user to
+# get the latest version. However, since it's listed as an optional
+# dependency for pipe-viewer (and might be useful as a dep for other
+# things), it has to exist on SBo.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=yt-dlp
+VERSION=${VERSION:-2022.01.21}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# no need for CFLAGS or LIBDIRSUFFIX. actually this would be noarch,
+# except for the lib vs. lib64 python problem.
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM.tar.gz
+cd $PRGNAM
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# hardcoded paths.
+sed -i -e "s,share/doc/yt_dlp,doc/$PRGNAM-$VERSION," \
+ -e "s,share/man,man," \
+ setup.py
+
+# if anyone's wondering, there's no python2 support.
+python3 setup.py install --root=$PKG
+
+gzip -9 $PKG/usr/man/man1/*
+
+# AUTHORS is 0 bytes in 2022.01.21
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a CONTRIBUTORS LICENSE *.md $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/yt-dlp/yt-dlp.info b/network/yt-dlp/yt-dlp.info
new file mode 100644
index 0000000000..5945eefeb6
--- /dev/null
+++ b/network/yt-dlp/yt-dlp.info
@@ -0,0 +1,10 @@
+PRGNAM="yt-dlp"
+VERSION="2022.01.21"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp"
+DOWNLOAD="https://github.com/yt-dlp/yt-dlp/releases/download/2022.01.21/yt-dlp.tar.gz"
+MD5SUM="5cec1f9ba77e03f303932e9b5897d481"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"