summaryrefslogtreecommitdiff
path: root/system/linkchecker/linkchecker.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/linkchecker/linkchecker.SlackBuild')
-rw-r--r--system/linkchecker/linkchecker.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/linkchecker/linkchecker.SlackBuild b/system/linkchecker/linkchecker.SlackBuild
index 8d15dd0bdd..6e7375b2b9 100644
--- a/system/linkchecker/linkchecker.SlackBuild
+++ b/system/linkchecker/linkchecker.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for linkchecker
-# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2013-2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=linkchecker
SRCNAM=LinkChecker
VERSION=${VERSION:-9.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,6 +70,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix python requests version check
+# https://github.com/wummel/linkchecker/commit/c2ce810c3fb00b895a841a7be6b2e78c64e7b042
+patch -p1 < $CWD/fix-python-requests.patch
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \