summaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python3-automat/optional_m2r.diff11
-rw-r--r--python/python3-automat/python3-automat.SlackBuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/python/python3-automat/optional_m2r.diff b/python/python3-automat/optional_m2r.diff
new file mode 100644
index 0000000000..87e0ddc6bd
--- /dev/null
+++ b/python/python3-automat/optional_m2r.diff
@@ -0,0 +1,11 @@
+diff -Naur Automat-20.2.0.orig/setup.py Automat-20.2.0/setup.py
+--- Automat-20.2.0.orig/setup.py 2020-02-17 04:33:10.000000000 +0900
++++ Automat-20.2.0/setup.py 2022-10-31 21:14:14.926665030 +0900
+@@ -24,7 +24,6 @@
+ package_dir={'automat': 'automat'},
+ setup_requires=[
+ 'setuptools-scm',
+- 'm2r',
+ ],
+ install_requires=[
+ "attrs>=19.2.0",
diff --git a/python/python3-automat/python3-automat.SlackBuild b/python/python3-automat/python3-automat.SlackBuild
index 5f2a7c887a..cb88118c7c 100644
--- a/python/python3-automat/python3-automat.SlackBuild
+++ b/python/python3-automat/python3-automat.SlackBuild
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-automat
SRCNAM=Automat
VERSION=${VERSION:-20.2.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -75,6 +75,7 @@ cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
+cat $CWD/optional_m2r.diff | patch -p1
chown -R root:root .
find -L . \