summaryrefslogtreecommitdiff
path: root/network/mozplugger/mozplugger.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/mozplugger/mozplugger.SlackBuild')
-rw-r--r--network/mozplugger/mozplugger.SlackBuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/network/mozplugger/mozplugger.SlackBuild b/network/mozplugger/mozplugger.SlackBuild
new file mode 100644
index 0000000000..866d7d9140
--- /dev/null
+++ b/network/mozplugger/mozplugger.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+# Slackware Build Script for mozplugger
+# (C) 2007 Michael Wagner <lapinours@web.de>
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 2 of the License, or (at your
+# option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
+# Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+#
+
+# Modified by the SlackBuild Project
+
+set -e
+
+PRGNAM=mozplugger
+VERSION=1.8.1
+VERSION=$VERSION
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING ChangeLog README"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.* || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Patch Makefile ($ARCH, /usr/man)
+if [ $ARCH = i486 ]; then
+ patch -p0 < $CWD/Makefile_i486.diff || exit 1
+elif [ $ARCH = i686 ]; then
+ patch -p0 < $CWD/Makefile_i686.diff || exit 1
+fi
+
+# Change installation prefix
+sed -i "s?\(root=\)?\1 $PKG?g" Makefile
+make linux || exit 1
+make install || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -name "*.?" -type f 2> /dev/null | xargs gzip -9 2> /dev/null
+ for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+
+# Don't override custom changes to muzpluggerrc
+mv $PKG/etc/mozpluggerrc /$PKG/etc/mozpluggerrc.new
+
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz