summaryrefslogtreecommitdiff
path: root/network/exim/exim.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/exim/exim.SlackBuild')
-rw-r--r--network/exim/exim.SlackBuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index c859c766b2..f04b3ba9e6 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=exim
-VERSION=${VERSION:-4.90.1}
+VERSION=${VERSION:-4.91}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -81,19 +81,13 @@ find -L . \
# See README.SBo for info on how to enable the database lookups.
cat $CWD/exim.Makefile > Local/Makefile
+# Add our SLKCFLAGS to the custom Makefile
+echo "CFLAGS += $SLKCFLAGS" >> Local/Makefile
+
# Use a stock config for the Exim Monitor (not built by default).
cat exim_monitor/EDITME > Local/eximon.conf
-# Use the Exim build system to set the architecture-specific CFLAGS.
-# This requires "make" to run twice, in case you wonder. If you want
-# to use your own CFLAGS in exim.Makefile, you should put a '#' in
-# front of the next 3 lines.
-echo "CFLAGS=$SLKCFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux
-FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e || true
-FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e makefile
-
-# build & install
-FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e
+# Build and install.
FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e install
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \