summaryrefslogtreecommitdiff
path: root/multimedia/ekiga/ekiga.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/ekiga/ekiga.SlackBuild')
-rw-r--r--multimedia/ekiga/ekiga.SlackBuild40
1 files changed, 22 insertions, 18 deletions
diff --git a/multimedia/ekiga/ekiga.SlackBuild b/multimedia/ekiga/ekiga.SlackBuild
index 1ea14fd9bf..f041d477c0 100644
--- a/multimedia/ekiga/ekiga.SlackBuild
+++ b/multimedia/ekiga/ekiga.SlackBuild
@@ -4,14 +4,14 @@
# Written by Olivier Esser (olive001@tele2allin.be), based on
# the template available at slackbuilds.org (public domain)
-
# Modified by Robby Workman <rworkman@slackbuilds.org>
PRGNAM=ekiga
-VERSION=2.0.11
+VERSION=2.0.12
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -21,9 +21,11 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
-set -e # Exit on most errors
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -34,26 +36,29 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Small patch to allow building on gcc-4.x
-patch -p1 < $CWD/ekiga-2.0.11-gcc4_fix.diff
+# Fix a bug in the configure script that does not complete when
+# Gnome is disabled. This is a ugly hack; the proper way
+# would be to fix configure.in, but I am uncomfortable with autoconf.
+patch -p0 < $CWD/configure_fix.diff
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --disable-gnome \
- --disable-avahi
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-gnome \
+ --disable-avahi \
+ --disable-static \
+ --build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
@@ -61,9 +66,8 @@ make install DESTDIR=$PKG
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog FAQ INSTALL \
- LICENSE MAINTAINERS NEWS README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog FAQ INSTALL LICENSE \
+ MAINTAINERS NEWS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install