summaryrefslogtreecommitdiff
path: root/misc/xvnkb/patches
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xvnkb/patches')
-rw-r--r--misc/xvnkb/patches/gimp-segfault.patch29
-rw-r--r--misc/xvnkb/patches/kdeinit-error.patch12
-rw-r--r--misc/xvnkb/patches/power-consumption.patch18
3 files changed, 59 insertions, 0 deletions
diff --git a/misc/xvnkb/patches/gimp-segfault.patch b/misc/xvnkb/patches/gimp-segfault.patch
new file mode 100644
index 0000000000..3ff7d42c7c
--- /dev/null
+++ b/misc/xvnkb/patches/gimp-segfault.patch
@@ -0,0 +1,29 @@
+diff -urN xvnkb.cvs/Makefile.common xvnkb/Makefile.common
+--- xvnkb.cvs/Makefile.common 2005-01-12 04:21:04.000000000 -0600
++++ xvnkb/Makefile.common 2009-07-09 10:37:22.491007609 -0500
+@@ -6,7 +6,7 @@
+ .PHONY: config debug core core_debug tools uninstall
+
+ CORE=xvnkb.so.$(VERSION)
+-CORE_OBJS=xvnkb.o visckey.o property.o
++CORE_OBJS=xvnkb.o visckey.o
+
+ GUI=xvnkb
+ GUI_OBJS=data.o flash.o main.o event.o mainwin.o menu.o hotkey.o systray.o \
+diff -urN xvnkb.cvs/xvnkb.c xvnkb/xvnkb.c
+--- xvnkb.cvs/xvnkb.c 2009-06-27 06:32:54.000000000 -0500
++++ xvnkb/xvnkb.c 2009-07-09 10:37:02.505973519 -0500
+@@ -49,7 +49,7 @@
+ long sym;
+ } vk_hotkey_info;
+ /*----------------------------------------------------------------------------*/
+-Window root = -1;
++static Window root = -1;
+ Window focus = -1;
+ /*----------------------------------------------------------------------------*/
+ static KeyCode rk = 0;
+@@ -422,3 +422,4 @@
+ return 0;
+ }
+ /*----------------------------------------------------------------------------*/
++#include "property.c"
diff --git a/misc/xvnkb/patches/kdeinit-error.patch b/misc/xvnkb/patches/kdeinit-error.patch
new file mode 100644
index 0000000000..849bcd1092
--- /dev/null
+++ b/misc/xvnkb/patches/kdeinit-error.patch
@@ -0,0 +1,12 @@
+diff -urN xvnkb.cvs/Makefile.common xvnkb/Makefile.common
+--- xvnkb.cvs/Makefile.common 2005-01-12 04:21:04.000000000 -0600
++++ xvnkb/Makefile.common 2009-07-09 12:44:28.789974861 -0500
+@@ -19,7 +19,7 @@
+ $(CC) -fpic $(CFLAGS) $(FPTR) $(VK_OPT) -DVERSION=\"$(VERSION)\" -Wall -I$(XLIB_INC) -c $<
+
+ $(CORE): $(CORE_OBJS)
+- $(CC) $(CFLAGS) $(DLFLAGS) $(CORE_OBJS) -o $@ -L$(XLIB_PATH) $(LIBDL)
++ $(CC) $(CFLAGS) $(DLFLAGS) $(CORE_OBJS) -o $@ -L$(XLIB_PATH) $(LIBDL) -lX11
+
+ $(GUI): $(GUI_OBJS)
+ $(CC) $(CFLAGS) $(GUI_OBJS) -o $@ -L$(XLIB_PATH) $(LIBS) $(XFT_LIBS)
diff --git a/misc/xvnkb/patches/power-consumption.patch b/misc/xvnkb/patches/power-consumption.patch
new file mode 100644
index 0000000000..99130bf71f
--- /dev/null
+++ b/misc/xvnkb/patches/power-consumption.patch
@@ -0,0 +1,18 @@
+--- main.c 2006/02/25 20:31:25 1.7
++++ main.c 2009/06/27 11:10:55 1.8
+@@ -89,8 +89,14 @@
+ /*----------------------------------------------------------------------------*/
+ void VKMainProcess()
+ {
++ int xfd = ConnectionNumber(display);
++
+ while( !vk_done ) {
+- usleep(1000);
++ struct timeval tv = {1, 0};
++ fd_set rfds;
++ FD_ZERO(&rfds);
++ FD_SET(xfd, &rfds);
++ select(xfd+1, &rfds, 0, 0, &tv);
+
+ if( vk_timeout && vk_flash_on )
+ VKHideFlash();