summaryrefslogtreecommitdiff
path: root/misc/xlog/xlog.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/xlog/xlog.SlackBuild')
-rw-r--r--misc/xlog/xlog.SlackBuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/misc/xlog/xlog.SlackBuild b/misc/xlog/xlog.SlackBuild
index ad5772afab..1808b39f76 100644
--- a/misc/xlog/xlog.SlackBuild
+++ b/misc/xlog/xlog.SlackBuild
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=xlog
-VERSION=2.0.3
+VERSION=2.0.5
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -69,6 +67,17 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
+# As upstreams INSTALL file mentions, packagers should not run
+# 'update-mime-database' neither 'update-desktop-database' and
+# this should be disabled by default and enabled (if so desired)
+# with --enable-mime-update. But...
+# Make still runs 'update-desktop-database', creating a new
+# index that would overwrite the one on the box receiving the
+# package.
+# This fixes it in the Makefile.in:
+sed "/^@HAVE_DESKTOP_TRUE/s/\(@HAVE_DESKTOP_TRUE@\)/\1@MIMEUPDATE_TRUE@/g" \
+ -i data/desktop/Makefile.in
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \