summaryrefslogtreecommitdiff
path: root/libraries/pygame/pygame.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/pygame/pygame.SlackBuild')
-rw-r--r--libraries/pygame/pygame.SlackBuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/libraries/pygame/pygame.SlackBuild b/libraries/pygame/pygame.SlackBuild
deleted file mode 100644
index e0242ddbe6..0000000000
--- a/libraries/pygame/pygame.SlackBuild
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/bin/sh
-
-## Written by hollywoodb (hollywoodb@fastmail.fm)
-# Modified by the SlackBuilds.org project
-
-NAME=pygame
-VERSION=1.7.1
-BUILD=${BUILD:-3}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$NAME
-OUTPUT=${OUTPUT:-/tmp}
-
-SRCVERSION=${VERSION}release
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
-rm -rf $NAME-$SRCVERSION
-tar xvf $CWD/$NAME-$SRCVERSION.tar.?z* || exit 1
-cd $NAME-$SRCVERSION || exit 1
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Python programs use the CFLAGS specified used by python itself
-python -u config.py || exit 1
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$NAME-$VERSION
-cp -a PKG-INFO WHATSNEW install.html readme.txt docs/* examples \
- $PKG/usr/doc/$NAME-$VERSION
-cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}