summaryrefslogtreecommitdiff
path: root/libraries/mmpython/mmpython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/mmpython/mmpython.SlackBuild')
-rw-r--r--libraries/mmpython/mmpython.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/libraries/mmpython/mmpython.SlackBuild b/libraries/mmpython/mmpython.SlackBuild
index 393c90a6f5..c0af3e4e16 100644
--- a/libraries/mmpython/mmpython.SlackBuild
+++ b/libraries/mmpython/mmpython.SlackBuild
@@ -38,8 +38,10 @@ python setup.py build
python setup.py install --prefix="$PKG/usr"
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -50,4 +52,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}