summaryrefslogtreecommitdiff
path: root/libraries/libpgf/libpgf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libpgf/libpgf.SlackBuild')
-rw-r--r--libraries/libpgf/libpgf.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/libraries/libpgf/libpgf.SlackBuild b/libraries/libpgf/libpgf.SlackBuild
index 4d4ce30ab4..3ef7836902 100644
--- a/libraries/libpgf/libpgf.SlackBuild
+++ b/libraries/libpgf/libpgf.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2012-2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2012-2017 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,8 +21,9 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libpgf
-VERSION=${VERSION:-6.14.12}
-BUILD=${BUILD:-2}
+SRCNAM=libPGF-codec-and-console-src
+VERSION=${VERSION:-7.15.32}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,9 +58,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-src-$VERSION.tar.gz
-cd $PRGNAM
+rm -rf PGF
+unzip $CWD/$SRCNAM.zip
+cd PGF/Codec
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,7 +70,7 @@ find -L . \
fromdos < configure.ac > configure.ac.new
mv configure.ac.new configure.ac
-./autogen.sh
+sh ./autogen.sh
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -84,7 +85,6 @@ make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done