summaryrefslogtreecommitdiff
path: root/games/ivan/ivan.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/ivan/ivan.SlackBuild')
-rw-r--r--games/ivan/ivan.SlackBuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/games/ivan/ivan.SlackBuild b/games/ivan/ivan.SlackBuild
new file mode 100644
index 0000000000..1787b5c270
--- /dev/null
+++ b/games/ivan/ivan.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+## Written by hollywoodb
+
+## Feel free to use, modify, redistribute this script.
+## If you make changes please modify the "Written by"
+## so that I don't recieve emails about a script I
+## did not write. Thanks.
+# Modified by Niklas 'Nille' Åkerström for slackware 12.1
+# and removed hollywoodb's email
+# Any questions about this script should be emailed to nille.kungen [at] gmail.com
+
+PRGNAM=ivan
+VERSION=0.50
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG $TMP/$PRGNAM-$VERSION
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+tar zxvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+# Fix Makefile.in so that it does mkdir, chown, and chmod within
+# DESTDIR like it is supposed to. Also fix own/perm settings on
+# /usr/games/ivan executable
+patch -p0 < $CWD/Makefile.in-install.patch || exit 1
+# gcc4.1 and 4.2 needs this gentoo patch to compile.
+patch -p0 < $CWD/ivan-0.50-gcc41.patch || exit 1
+#patch to fix crash when choosing continue in game
+# CFLAGS="$SLKCFLAGS -fno-strict-aliasing" and CXXFLAGS="$SLKCFLAGS -fno-strict-aliasing" may also work.
+zcat $CWD/ivan-0.50-continue_game.patch.gz | patch -p1 --verbose --backup --suffix=.orig || exit 1
+# use HOME=.ivansave instead of HOME=IvanSave
+sed -i -e 's/IvanSave/.ivansave/' $TMP/$PRGNAM-$VERSION/Main/Source/game.cpp
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/games \
+ --datadir=/usr/share/games \
+ --libdir=/usr/lib/games \
+ --sysconfdir=/etc \
+ --localstatedir=/var/games \
+ || exit 1
+
+make || exit 1
+make install DESTDIR=$PKG || exit 1
+
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+install -m 0644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/
+
+find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a {AUTHORS,COPYING,ChangeLog,LICENSING,INSTALL} $PKG/usr/doc/$PRGNAM-$VERSION
+chmod -x $PKG/usr/doc/$PRGNAM-$VERSION/*
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz