summaryrefslogtreecommitdiff
path: root/games/bsnes/bsnes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/bsnes/bsnes.SlackBuild')
-rw-r--r--games/bsnes/bsnes.SlackBuild46
1 files changed, 27 insertions, 19 deletions
diff --git a/games/bsnes/bsnes.SlackBuild b/games/bsnes/bsnes.SlackBuild
index 22a62f5306..f3625a7141 100644
--- a/games/bsnes/bsnes.SlackBuild
+++ b/games/bsnes/bsnes.SlackBuild
@@ -5,8 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=bsnes
-VERSION=${VERSION:-0.082}
-SRCVER=${VERSION:2}
+VERSION=${VERSION:-091}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -42,9 +41,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf ${PRGNAM}_v${SRCVER}-source
-tar xvf $CWD/${PRGNAM}_v${SRCVER}-source.tar.bz2
-cd ${PRGNAM}_v${SRCVER}-source
+rm -rf ${PRGNAM}_v${VERSION}-source
+tar xvf $CWD/${PRGNAM}_v${VERSION}-source.tar.xz
+cd ${PRGNAM}_v${VERSION}-source
find . -type d -exec chmod -R 0755 {} \;
chown -R root:root .
find . \
@@ -53,18 +52,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch makefile so SLKCFLAGS are recognized.
-patch -p1 < $CWD/bsnes-0.077-makefile.patch
-
cd $PRGNAM
-# Remove pulseaudio as there is no package for it at SBo.
-# Comment out or delete the following 4 lines to enable pulseaudio.
-sed -i \
- -e 's|audio.pulseaudio ||' \
- -e 's|audio.pulseaudiosimple ||' \
- -e '/pulse/d' ui{,-gameboy}/Makefile
+sed -e 's|audio.pulseaudio ||' \
+ -e 's|audio.pulseaudiosimple ||' \
+ -i 'target-ethos/Makefile'
+moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
+sed -e 's/sudo install/install/' \
+ -i 'target-ethos/Makefile'
# Choose whether qt or gtk interface is used. Qt4 is default.
if [ "${INTERFACE:-QT4}" != 'QT4' ]; then
PHOENIX='gtk'
@@ -84,20 +80,32 @@ make \
phoenix="$PHOENIX" \
profile="$PROFILE"
-make install DESTDIR=$PKG prefix=/usr
+make install profile=$PROFILE DESTDIR=$PKG prefix=/usr
cd ..
# Compile snespurify. It helps clean up ROMS for use with bsnes.
-cd snespurify
+cd purify
+# Fix building with QT >= 4.8.0.
+moc -i -Iphoenix/qt/ -o phoenix/qt/platform.moc phoenix/qt/platform.moc.hpp
+
# Fix snespurify scripts.
-sed -i -e 's|g++-4.5|g++|g' -e "s|-O3|$SLKCFLAGS|" cc-${PHOENIX}.sh
-./cc-${PHOENIX}.sh
-install -m 0755 snespurify-$PHOENIX $PKG/usr/bin
+sed -e 's|link := -s|link := -s -lX11|' -i 'Makefile'
+
+make \
+ compiler=gcc \
+ platform=x \
+ phoenix="$PHOENIX"
+
+mkdir -p $PKG/usr/bin
+install -m 0755 purify $PKG/usr/bin/$PRGNAM-purify
cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mkdir -p $PKG/usr/share/$PRGNAM/profile
+cp -R bsnes/profile/* $PKG/usr/share/$PRGNAM/profile
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild