summaryrefslogtreecommitdiff
path: root/system/ttyrec/ttyrec-1.0.8.RHEL5.patch
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2015-07-02 12:58:24 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2015-07-04 10:38:14 +0700
commitef100fc9277d6395f1a1fdca496d8d86abeae5f6 (patch)
tree0483f7d4e9041c5314e85df2bbf960fe4cf49780 /system/ttyrec/ttyrec-1.0.8.RHEL5.patch
parent29e42556dcffd5814fb1f2bbada33352df3d6165 (diff)
downloadslackbuilds-ef100fc9277d6395f1a1fdca496d8d86abeae5f6.tar.gz
system/ttyrec: Added (tty recorder).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/ttyrec/ttyrec-1.0.8.RHEL5.patch')
-rw-r--r--system/ttyrec/ttyrec-1.0.8.RHEL5.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/system/ttyrec/ttyrec-1.0.8.RHEL5.patch b/system/ttyrec/ttyrec-1.0.8.RHEL5.patch
new file mode 100644
index 0000000000..900b017cb9
--- /dev/null
+++ b/system/ttyrec/ttyrec-1.0.8.RHEL5.patch
@@ -0,0 +1,33 @@
+diff -rupN original/Makefile new/Makefile
+--- original/Makefile 2006-06-11 10:52:50.000000000 -0500
++++ new/Makefile 2012-04-23 18:34:05.000000000 -0500
+@@ -1,5 +1,5 @@
+ CC = gcc
+-CFLAGS = -O2
++CFLAGS = -O2 -DHAVE_openpty
+ VERSION = 1.0.8
+
+ TARGET = ttyrec ttyplay ttytime
+@@ -10,7 +10,7 @@ DIST = ttyrec.c ttyplay.c ttyrec.h io.c
+ all: $(TARGET)
+
+ ttyrec: ttyrec.o io.o
+- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
++ $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o -lutil
+
+ ttyplay: ttyplay.o io.o
+ $(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
+diff -rupN original/ttyrec.c new/ttyrec.c
+--- original/ttyrec.c 2006-06-11 10:52:50.000000000 -0500
++++ new/ttyrec.c 2012-04-23 18:26:41.000000000 -0500
+@@ -71,7 +71,9 @@
+ #define _(FOO) FOO
+
+ #ifdef HAVE_openpty
+-#include <libutil.h>
++/* #include <libutil.h> */
++#include <pty.h> /* for openpty and forkpty */
++#include <utmp.h> /* for login_tty */
+ #endif
+
+ #if defined(SVR4) && !defined(CDEL)