summaryrefslogtreecommitdiff
path: root/system/ksh-openbsd/oksh.patch
diff options
context:
space:
mode:
authorHunter Sezen <orbea@fredslev.dk>2019-02-08 20:53:53 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-02-08 20:53:53 +0700
commit06a99f4aa15c8cfec1fa88e58579d7760bd548f4 (patch)
tree34151131065c95cf950284dcb51de4dfadbded15 /system/ksh-openbsd/oksh.patch
parentae12f0de00055080b996422053a4d685f7d1fb3b (diff)
downloadslackbuilds-06a99f4aa15c8cfec1fa88e58579d7760bd548f4.tar.gz
system/ksh-openbsd: Updated for version 20190127 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/ksh-openbsd/oksh.patch')
-rw-r--r--system/ksh-openbsd/oksh.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/system/ksh-openbsd/oksh.patch b/system/ksh-openbsd/oksh.patch
new file mode 100644
index 0000000000..00d1c7ea0f
--- /dev/null
+++ b/system/ksh-openbsd/oksh.patch
@@ -0,0 +1,37 @@
+commit 2e3b7a715793bbb9fe857b37ffaad44b076e3e12
+Author: orbea <orbea@fredslev.dk>
+Date: Sat Oct 20 19:54:17 2018 -0700
+
+ Makefile: Support a custom binary name.
+
+diff --git a/Makefile b/Makefile
+index 6b96f38..707ab5e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,6 +3,7 @@ PREFIX = $(PREFIX)
+ else
+ PREFIX = /usr
+ endif
++BINNAM = pdksh
+ BINDIR = $(DESTDIR)/bin
+ MANDIR = $(DESTDIR)$(PREFIX)/man
+ TMP ?= /tmp
+@@ -33,14 +34,14 @@ all: $(PROG)
+
+ check test:
+ /usr/bin/perl tests/th -s tests -p ./ksh -T $(TMP) \
+- -C pdksh,sh,ksh,posix,posix-upu
++ -C $(BINNAM),sh,ksh,posix,posix-upu
+
+ install:
+ install -m755 -d $(BINDIR)
+- install -m755 --strip --no-target-directory ksh $(BINDIR)/pdksh
++ install -m755 --strip --no-target-directory ksh $(BINDIR)/$(BINNAM)
+ install -m755 -d $(MANDIR)/man1
+- install -m644 --no-target-directory ksh.1 $(MANDIR)/man1/pdksh.1
+- install -m644 --no-target-directory sh.1 $(MANDIR)/man1/pdksh-sh.1
++ install -m644 --no-target-directory ksh.1 $(MANDIR)/man1/$(BINNAM).1
++ install -m644 --no-target-directory sh.1 $(MANDIR)/man1/$(BINNAM)-sh.1
+
+ clean:
+ rm -f $(OBJS) $(PROG)