summaryrefslogtreecommitdiff
path: root/python/waitress/waitress.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2019-11-16 23:09:17 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-11-23 16:02:03 +0700
commitca020de0ff47554cdf10dee5d69f88376577e3de (patch)
treede3c8c8148714c335ee4dd5e2d6e27d7a5daad2a /python/waitress/waitress.SlackBuild
parent8e268e60524fa81f82da7a5bd0c4f0c46d955c19 (diff)
downloadslackbuilds-ca020de0ff47554cdf10dee5d69f88376577e3de.tar.gz
python/waitress: Updated for version 1.3.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/waitress/waitress.SlackBuild')
-rw-r--r--python/waitress/waitress.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/waitress/waitress.SlackBuild b/python/waitress/waitress.SlackBuild
index 443e6012a3..412e78de01 100644
--- a/python/waitress/waitress.SlackBuild
+++ b/python/waitress/waitress.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for waitress
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=waitress
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true