summaryrefslogtreecommitdiff
path: root/network/python-uuid
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /network/python-uuid
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/python-uuid')
-rw-r--r--network/python-uuid/README3
-rw-r--r--network/python-uuid/python-uuid.SlackBuild84
-rw-r--r--network/python-uuid/python-uuid.info10
-rw-r--r--network/python-uuid/slack-desc22
4 files changed, 0 insertions, 119 deletions
diff --git a/network/python-uuid/README b/network/python-uuid/README
deleted file mode 100644
index 5a99b95273..0000000000
--- a/network/python-uuid/README
+++ /dev/null
@@ -1,3 +0,0 @@
-UUID object and generation functions (Python 2.3 or higher)
-
-
diff --git a/network/python-uuid/python-uuid.SlackBuild b/network/python-uuid/python-uuid.SlackBuild
deleted file mode 100644
index adc507ca1b..0000000000
--- a/network/python-uuid/python-uuid.SlackBuild
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-uuid
-# Copyright 2010 David Woodfall <dave@dawoodfall.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=uuid
-PRGNAM=python-$SRCNAM
-VERSION=${VERSION:-1.30}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-uuid/python-uuid.info b/network/python-uuid/python-uuid.info
deleted file mode 100644
index ca5fc86be7..0000000000
--- a/network/python-uuid/python-uuid.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-uuid"
-VERSION="1.30"
-HOMEPAGE="http://pypi.python.org/pypi/uuid/1.30"
-DOWNLOAD="http://pypi.python.org/packages/source/u/uuid/uuid-1.30.tar.gz"
-MD5SUM="639b310f1fe6800e4bf8aa1dd9333117"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="David Woodfall"
-EMAIL="dave@dawoodfall.net"
-APPROVED="dsomero"
diff --git a/network/python-uuid/slack-desc b/network/python-uuid/slack-desc
deleted file mode 100644
index d13ce59899..0000000000
--- a/network/python-uuid/slack-desc
+++ /dev/null
@@ -1,22 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python-uuid: python-uuid ( UUID object and generation functions )
-python-uuid:
-python-uuid: UUID object and generation functions (Python 2.3 or higher)
-python-uuid:
-python-uuid: Homepage: http://pypi.python.org/pypi/uuid/1.30
-python-uuid:
-python-uuid:
-python-uuid:
-python-uuid:
-python-uuid:
-python-uuid:
-
-
-