summaryrefslogtreecommitdiff
path: root/network/python-suds
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /network/python-suds
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/python-suds')
-rw-r--r--network/python-suds/README3
-rw-r--r--network/python-suds/python-suds.SlackBuild55
-rw-r--r--network/python-suds/python-suds.info10
-rw-r--r--network/python-suds/slack-desc19
4 files changed, 0 insertions, 87 deletions
diff --git a/network/python-suds/README b/network/python-suds/README
deleted file mode 100644
index 14650e2966..0000000000
--- a/network/python-suds/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Suds is a lightweight SOAP python client for consuming Web Services.
-
-This requires pysetuptools.
diff --git a/network/python-suds/python-suds.SlackBuild b/network/python-suds/python-suds.SlackBuild
deleted file mode 100644
index fb097c17f0..0000000000
--- a/network/python-suds/python-suds.SlackBuild
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-suds
-# Written by Joey Trungale <joey@trungale.net>
-
-PRGNAM=python-suds
-VERSION=${VERSION:-0.3.9}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="LICENSE README"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-suds/python-suds.info b/network/python-suds/python-suds.info
deleted file mode 100644
index eaf0704eb8..0000000000
--- a/network/python-suds/python-suds.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-suds"
-VERSION="0.3.9"
-HOMEPAGE="https://fedorahosted.org/suds/"
-DOWNLOAD="https://fedorahosted.org/releases/s/u/suds/python-suds-0.3.9.tar.gz"
-MD5SUM="420ac4b6ba788e43631b74719a470bf7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Joey Trungale"
-EMAIL="joey@trungale.net"
-APPROVED="rworkman"
diff --git a/network/python-suds/slack-desc b/network/python-suds/slack-desc
deleted file mode 100644
index ca8b6eb117..0000000000
--- a/network/python-suds/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-python-suds: python-suds (Python SOAP client)
-python-suds:
-python-suds: Suds is a lightweight SOAP python client for consuming Web Services.
-python-suds:
-python-suds: https://fedorahosted.com/suds
-python-suds:
-python-suds:
-python-suds:
-python-suds:
-python-suds:
-python-suds: