summaryrefslogtreecommitdiff
path: root/libraries/pytables
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/pytables
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/pytables')
-rw-r--r--libraries/pytables/README19
-rw-r--r--libraries/pytables/pytables.SlackBuild96
-rw-r--r--libraries/pytables/pytables.info13
-rw-r--r--libraries/pytables/slack-desc19
4 files changed, 0 insertions, 147 deletions
diff --git a/libraries/pytables/README b/libraries/pytables/README
deleted file mode 100644
index 22120c6a4a..0000000000
--- a/libraries/pytables/README
+++ /dev/null
@@ -1,19 +0,0 @@
-PyTables is a package for managing hierarchical datasets
-and designed to efficiently and easily cope with extremely
-large amounts of data. It optimizes memory and disk resources
-so that data takes much less space than other solutions such
-as relational or object oriented databases.
-
-PyTables has been designed to fulfill the next requirements:
- 1. Allow to structure your data in a hierarchical way.
- 2. Easy to use. It implements the NaturalNaming scheme for
- allowing convenient access to the data.
- 3. All the cells in datasets can be multidimensional entities.
- 4. Most of the I/O operations speed should be only limited by
- the underlying I/O subsystem.
- 5. Enable the end user to save large datasets in a efficient
- way, i.e. each single byte of data on disk has to be
- represented by one byte plus a small fraction when loaded
- in memory.
-
-This requires numpy, numexpr, hdf5 and Cython.
diff --git a/libraries/pytables/pytables.SlackBuild b/libraries/pytables/pytables.SlackBuild
deleted file mode 100644
index 27c070852d..0000000000
--- a/libraries/pytables/pytables.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pytables
-
-# Copyright 2007-2010 LukenShiro <lukenshiro@ngi.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pytables
-VERSION=${VERSION:-2.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRC_PRGNAM=tables
-DOCFILES="RELEASE_NOTES.txt LICENSES/ MIGRATING_TO_2.x.txt THANKS \
- ANNOUNCE.txt LICENSE.txt PKG-INFO README.txt doc/html doc/scripts \
- doc/text doc/usersguide.pdf"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_PRGNAM-$VERSION
-tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
-cd $SRC_PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" python setup.py build install --prefix=/usr --root=$PKG
-
-# Copy examples, contrib, and bench files
-mkdir -p $PKG/usr/share/$PRGNAM/
-cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
-
-# Copy documentation files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cp $CWD/pytablesmanual-$VERSION.pdf $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pytables/pytables.info b/libraries/pytables/pytables.info
deleted file mode 100644
index 2b441328bd..0000000000
--- a/libraries/pytables/pytables.info
+++ /dev/null
@@ -1,13 +0,0 @@
-PRGNAM="pytables"
-VERSION="2.2"
-HOMEPAGE="http://www.pytables.org/moin"
-DOWNLOAD="http://www.pytables.org/download/pytables-2.2/tables-2.2.tar.gz \
- http://www.pytables.org/download/pytables-2.2/pytablesmanual-2.2.pdf"
-MD5SUM="b95ebb5e501296f30fd75254a689d57b \
- 61609ed51b1bfab0689dbbc3ca636cb3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
-APPROVED="Niels Horn"
-
diff --git a/libraries/pytables/slack-desc b/libraries/pytables/slack-desc
deleted file mode 100644
index ecf9f8542a..0000000000
--- a/libraries/pytables/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler----------------------------------------------------|
-pytables: pytables (Hierarchical datasets in Python)
-pytables:
-pytables: PyTables is a package for managing hierarchical datasets
-pytables: and designed to efficiently and easily cope with extremely
-pytables: large amounts of data. It optimizes memory and disk resources
-pytables: so that data takes much less space than other solutions such
-pytables: as relational or object oriented databases.
-pytables:
-pytables: Homepage: http://www.pytables.org/moin
-pytables:
-pytables: