summaryrefslogtreecommitdiff
path: root/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2020-04-23 10:41:24 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2020-04-24 08:18:56 +0700
commit73d4c3502f29964288dc71fd7ef93c2172c440e2 (patch)
tree65b7d69c7a5027931cc23806cdfb2b0a7c378f0f /libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
parent7779f1091b2bb12275c0731bd6b50b947cf0b478 (diff)
downloadslackbuilds-73d4c3502f29964288dc71fd7ef93c2172c440e2.tar.gz
libraries/BeautifulSoup4: Updated for version 4.9.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild')
-rw-r--r--libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild b/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
index 38b98401fa..5fe2f506d4 100644
--- a/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
+++ b/libraries/BeautifulSoup4/BeautifulSoup4.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for BeautifulSoup4
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,11 +24,12 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=BeautifulSoup4
-SRCNAM=${PRGNAM,,}
-VERSION=${VERSION:-4.6.1}
+VERSION=${VERSION:-4.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+SRCNAM=beautifulsoup4
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -70,10 +72,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+if $(python2 -c 'import soupsieve' 2>/dev/null); then
+ python setup.py install --root=$PKG
+fi
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
+# Python 3 support (requires python3-soupsieve)
+if $(python3 -c 'import soupsieve' 2>/dev/null); then
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
@@ -93,7 +97,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt COPYING.txt AUTHORS.txt NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md COPYING.txt NEWS.txt TODO.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install