summaryrefslogtreecommitdiff
path: root/games/ppsspp/ppsspp-no-ccache.patch
diff options
context:
space:
mode:
authorHunter Sezen <ovariegata@yahoo.com>2016-08-02 22:21:27 +0100
committerDavid Spencer <idlemoor@slackbuilds.org>2016-08-05 18:10:41 +0100
commitf4020cea36fdccdb57e02a64145aff9512d98d84 (patch)
tree83df1ebfa5b87edc536ad2faeb57045bf9d5f56c /games/ppsspp/ppsspp-no-ccache.patch
parent53956504b1c505c014d8727464a470e93326c8d3 (diff)
downloadslackbuilds-f4020cea36fdccdb57e02a64145aff9512d98d84.tar.gz
games/ppsspp: Added (fast and portable PSP emulator).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'games/ppsspp/ppsspp-no-ccache.patch')
-rw-r--r--games/ppsspp/ppsspp-no-ccache.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games/ppsspp/ppsspp-no-ccache.patch b/games/ppsspp/ppsspp-no-ccache.patch
new file mode 100644
index 0000000000..d8884925e4
--- /dev/null
+++ b/games/ppsspp/ppsspp-no-ccache.patch
@@ -0,0 +1,24 @@
+diff -u -r ppsspp-2016.07.25_fa3f219-orig/CMakeLists.txt ppsspp-2016.07.25_fa3f219/CMakeLists.txt
+--- ppsspp-2016.07.25_fa3f219-orig/CMakeLists.txt 2016-08-02 05:10:55.000000000 +0100
++++ ppsspp-2016.07.25_fa3f219/CMakeLists.txt 2016-08-02 21:56:56.983679009 +0100
+@@ -33,20 +33,6 @@
+ endif()
+ endif()
+
+-# Using ccache greatly improves the speed of our CI builds, let's enable for all.
+-# Without this, our CI can't use ccache for clang, for some reason.
+-find_program(CCACHE_FOUND ccache)
+-if(CCACHE_FOUND)
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
+- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
+-
+- # ccache uses -I when compiling without preprocessor, which makes clang complain.
+- if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Qunused-arguments -fcolor-diagnostics")
+- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Qunused-arguments -fcolor-diagnostics")
+- endif()
+-endif(CCACHE_FOUND)
+-
+ # Remove soon?
+ set(USE_FFMPEG ON)
+