summaryrefslogtreecommitdiff
path: root/development/pysetuptools
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /development/pysetuptools
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development/pysetuptools')
-rw-r--r--development/pysetuptools/README18
-rw-r--r--development/pysetuptools/pysetuptools.SlackBuild59
-rw-r--r--development/pysetuptools/pysetuptools.info10
-rw-r--r--development/pysetuptools/slack-desc19
4 files changed, 0 insertions, 106 deletions
diff --git a/development/pysetuptools/README b/development/pysetuptools/README
deleted file mode 100644
index 851e044f23..0000000000
--- a/development/pysetuptools/README
+++ /dev/null
@@ -1,18 +0,0 @@
-pysetuptools (a collection of enhancements to Python distutils)
-Note: the name of the source package is 'setuptools'. Since 'setuptools'
-is such a generic name, this package uses the name 'pysetuptools' to avoid
-any potential future conflicts. The actual installation paths and file
-names are not modified in any way.
-
-setuptools allow you to more easily build and distribute Python packages,
-especially ones that have dependencies on other packages.
-
-Packages built and distributed using setuptools look to the user like ordinary
-Python packages based on the distutils. Your users don't need to install or
-even know about setuptools in order to use them, and you don't have to include
-the entire setuptools package in your distributions. By including just a single
-bootstrap module (an 8K .py file), your package will automatically download and
-install setuptools if the user is building your package from source and doesn't
-have a suitable version already installed.
-
-Requires: >=python-2.3.5 on 32-bit systems >=python-2.4 on 64-bit systems
diff --git a/development/pysetuptools/pysetuptools.SlackBuild b/development/pysetuptools/pysetuptools.SlackBuild
deleted file mode 100644
index 7b443ad754..0000000000
--- a/development/pysetuptools/pysetuptools.SlackBuild
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-
-## Written by hollywoodb (hollywoodb@fastmail.fm)
-
-## Feel free to use, modify, redistribute this script.
-## If you make changes please modify the "Written by"
-## so that I don't recieve emails about a script I
-## did not write. Thanks.
-
-# Mofified by the SlackBuilds.org project
-
-# Maintained by Audrius Kažukauskas <audrius@neutrino.lt>
-
-PRGNAM=pysetuptools
-SRC_NAME=setuptools
-VERSION=0.6c11
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$SRC_NAME}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_NAME-$VERSION
-tar xvf $CWD/$SRC_NAME-$VERSION.tar.gz
-cd $SRC_NAME-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Don't need this.
-rm -f setuptools/*.exe
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pysetuptools/pysetuptools.info b/development/pysetuptools/pysetuptools.info
deleted file mode 100644
index c2fad893e2..0000000000
--- a/development/pysetuptools/pysetuptools.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pysetuptools"
-VERSION="0.6c11"
-HOMEPAGE="http://peak.telecommunity.com/DevCenter/setuptools"
-DOWNLOAD="http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz"
-MD5SUM="7df2a529a074f613b509fb44feefe74e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Audrius Kazukauskas"
-EMAIL="audrius@neutrino.lt"
-APPROVED="Erik Hanson"
diff --git a/development/pysetuptools/slack-desc b/development/pysetuptools/slack-desc
deleted file mode 100644
index 816e24c7c4..0000000000
--- a/development/pysetuptools/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pysetuptools: pysetuptools (a collection of enhancements to Python distutils)
-pysetuptools:
-pysetuptools: setuptools allow you to more easily build and distribute
-pysetuptools: Python packages, especially ones that have dependencies on
-pysetuptools: other packages
-pysetuptools:
-pysetuptools:
-pysetuptools:
-pysetuptools:
-pysetuptools:
-pysetuptools: